Данный форум не является официальным, создан для взаимной помощи пользователей ЕГИССО, все рекомендации и советы применяются на свой страх и риск. Никто ни за что ответственности не несет!

Партизанский форум про ЕГИССО

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.


Вы здесь » Партизанский форум про ЕГИССО » Регистрация и работа в ЕГИССО » crypto+DE отказывается работать с гостом 2001.


crypto+DE отказывается работать с гостом 2001.

Сообщений 1 страница 30 из 35

1

Добрый день.
Сегодня, при попытке подписать файлы для выгрузки в ЕГИССО программа crypto+DE стала выдавать сообщение, что не может работать с гостом 2001 после 31.12.2018 года.
Да, у крипто-про тоже было это ограничение, но они сами сняли его выпустив патч. Не могу найти такой же для crypto+DE. Буду благодарен за подсказку где взять.
Или без вариантов нужно требовать у поставщика информации (Администрация района) новую ЭЦП под 2012-м гостом?

0

2

АлексейРУО написал(а):

Добрый день.
Сегодня, при попытке подписать файлы для выгрузки в ЕГИССО программа crypto+DE стала выдавать сообщение, что не может работать с гостом 2001 после 31.12.2018 года.
Да, у крипто-про тоже было это ограничение, но они сами сняли его выпустив патч. Не могу найти такой же для crypto+DE. Буду благодарен за подсказку где взять.
Или без вариантов нужно требовать у поставщика информации (Администрация района) новую ЭЦП под 2012-м гостом?

на КриптоЛайне все работает с гостом 2001, Ссылка КриптоПро CSP в 2019 году

Отредактировано Mariya (2019-01-11 10:57:32)

0

3

АлексейРУО написал(а):

Добрый день.
Сегодня, при попытке подписать файлы для выгрузки в ЕГИССО программа crypto+DE стала выдавать сообщение, что не может работать с гостом 2001 после 31.12.2018 года.
Да, у крипто-про тоже было это ограничение, но они сами сняли его выпустив патч. Не могу найти такой же для crypto+DE. Буду благодарен за подсказку где взять.
Или без вариантов нужно требовать у поставщика информации (Администрация района) новую ЭЦП под 2012-м гостом?

можно подписывать файлы в программе КриптоЛайн. она ничего не требует.

0

4

Babay написал(а):

можно подписывать файлы в программе КриптоЛайн. она ничего не требует.

Как? корневые сертификаты  :D

0

5

Mariya написал(а):

Как? корневые сертификаты

:mad:

0

6

Если вы и раньше пользовались Crypto+DE, и у вас эта программа автоматически находила нужный сертификат с выполненными условиями по установке корневых и т.д. На сайте ЕГИССО в разделе обновлений было написано про изменение версии этой программы вот ссылка на обновлённую программу Ссылка У нас после обновления версии всё подписывает на старом ГОСТ.

Отредактировано user68 (2019-01-12 21:45:36)

0

7

user68 написал(а):

Если вы и раньше пользовались Crypto+DE, и у вас эта программа автоматически находила нужный сертификат с выполненными условиями по установке корневых и т.д. На сайте ЕГИССО в разделе обновлений было написано про изменение версии этой программы вот ссылка на обновлённую программу Ссылка У нас после обновления версии всё подписывает на старом ГОСТ.

Отредактировано user68 (Вчера 03:45:36)

Благодарю. Помогло! Всё подписывает.

0

8

Ребята ни один из ваших ссылок не работает.

Я так то уже ставил Crypto+DE 4.1.126.0. Выдает ошибку: "Ошибка. Криптосервер
Ошибка при выполнении подписания: Не удалось вычислить хэш: Криптопровайдер с алгоритмом хэширования 1.2.643.2.2.9 не найден."
Кто нить сталкивался с таким ?

Отредактировано Раймондо (2019-01-15 12:20:30)

0

9

Раймондо написал(а):

Ребята ни один из ваших ссылок не работает.

Я так то уже ставил Crypto+DE 4.1.126.0. Выдает ошибку: "Ошибка. Криптосервер
Ошибка при выполнении подписания: Не удалось вычислить хэш: Криптопровайдер с алгоритмом хэширования 1.2.643.2.2.9 не найден."
Кто нить сталкивался с таким ?

Отредактировано Раймондо (Сегодня 09:20:30)

сталкивался!!

Решение: Нужно сначало было удалить старую версию, а потом ставить новую.

0

10

После обновления на версию 4.1.126.0 не даёт выбрать нужный сертификат. При нажатии клавиши выбрать сертификат ничего не происходит. Выбирается автоматически первый попавшийся. Кто -нибудь сталкивался с этим?

0

11

simonoven написал(а):

После обновления на версию 4.1.126.0 не даёт выбрать нужный сертификат. При нажатии клавиши выбрать сертификат ничего не происходит. Выбирается автоматически первый попавшийся. Кто -нибудь сталкивался с этим?

У меня пишет "Не один из сертификатов не прошел в хранилище не прошел проверку на квалифицированность в соответствии с настройками", Не Сертификаты ФК, не сертификаты ИТК, не сертификаты СБИС. Весело, но пока нет времени разбираться. С ЭЦП с новым ГОСТом вообще красота, их ни одна система видеть не хочет.

0

12

Сисадмин из Карелии написал(а):

У меня пишет "Не один из сертификатов не прошел в хранилище не прошел проверку на квалифицированность в соответствии с настройками", Не Сертификаты ФК, не сертификаты ИТК, не сертификаты СБИС. Весело, но пока нет времени разбираться. С ЭЦП с новым ГОСТом вообще красота, их ни одна система видеть не хочет.

Пишут на форумах, обновить модуль crypto+DE

0

13

Mariya написал(а):

Сисадмин из Карелии написал(а):У меня пишет "Не один из сертификатов не прошел в хранилище не прошел проверку на квалифицированность в соответствии с настройками", Не Сертификаты ФК, не сертификаты ИТК, не сертификаты СБИС. Весело, но пока нет времени разбираться. С ЭЦП с новым ГОСТом вообще красота, их ни одна система видеть не хочет.Пишут на форумах, обновить модуль crypto+DE

Это с обновленным модулем. Со старым он видит сертификат со старым алгоритмом, но не подписывает.

0

14

Сисадмин из Карелии написал(а):

Mariya написал(а):

    Сисадмин из Карелии написал(а):У меня пишет "Не один из сертификатов не прошел в хранилище не прошел проверку на квалифицированность в соответствии с настройками", Не Сертификаты ФК, не сертификаты ИТК, не сертификаты СБИС. Весело, но пока нет времени разбираться. С ЭЦП с новым ГОСТом вообще красота, их ни одна система видеть не хочет.Пишут на форумах, обновить модуль crypto+DE

Это с обновленным модулем. Со старым он видит сертификат со старым алгоритмом, но не подписывает.

Вот это верно! есть такая проблема

Отредактировано simonoven (2019-01-16 10:17:13)

0

15

У кого есть контакты разработчика?

crypto+DE

0

16

Добрый всем, пытался загрузить точку присутствия и подписать файл Crypto+DE, написал что подпись не предназначенная для шифрования и т.д. Попробовал Такском Криптолайн все подписало, но сам портал Егиссо не пропускает пишет Ошибка отправки ПВСС, неужели нужно делать новую подпись по ГОСТ -2012?. Крипто про стоит 4.0.9944. Крипто-Де последняя с официального сайта ПФР. и Крипто ДЕ пишет сертификат по умолчанию не соответствует требованиям текущего режима КЭП.

Отредактировано Сисадмин из Калмыкии (2019-01-16 10:50:50)

0

17

Пока писал сообщение, смог подписать Крипто Де и отправить на портал)

0

18

Сисадмин из Калмыкии написал(а):

Добрый всем, пытался загрузить точку присутствия и подписать файл Crypto+DE, написал что подпись не предназначенная для шифрования и т.д. Попробовал Такском Криптолайн все подписало, но сам портал Егиссо не пропускает пишет Ошибка отправки ПВСС, неужели нужно делать новую подпись по ГОСТ -2012?. Крипто про стоит 4.0.9944. Крипто-Де последняя с официального сайта ПФР. и Крипто ДЕ пишет сертификат по умолчанию не соответствует требованиям текущего режима КЭП.

Отредактировано Сисадмин из Калмыкии (Сегодня 07:50:50)

Ставили поверх старой версии или через удаление?
Меняли ли настройки программы?

Отредактировано simonoven (2019-01-16 12:32:18)

0

19

Я уже решил проблему, отредактировал настройки Крипто Де

0

20

Сисадмин из Калмыкии написал(а):

Я уже решил проблему, отредактировал настройки Крипто Де


что конкретно меняли, можете подробнее написать или приложить принтскрины настроек. которые меняли?

0

21

Режим проверки - с помощью списка отзыва сертификата с подключением к сети. Режим проверки ЭП- не проверять. Ругаться на эцп она не перестала, зато теперь подписывает.

0

22

А работает ли кнопка выбора сертификата?

0

23

simonoven написал(а):

А работает ли кнопка выбора сертификата?

И кнопка выбора сертификата стала работать, и выбор возможен, и сертификаты видны, и подписывать стала. И без ошибок загружается на Портал.

0

24

Вот, что пишет приложение при подписании:

16 Jan 2019 17:11:09 - Ошибка. Криптосервер
Ошибка при выполнении подписания: Не удалось вычислить хэш: Криптопровайдер с алгоритмом хэширования 1.2.643.2.2.9 не найден.

При этом на ПК стоит Код Безопасности CSP, может в этом проблема?

0

25

simonoven написал(а):

Код Безопасности CSP

То есть стоит не КриптоПро CSP 4.0, а Код Безопасности CSP. Или они в связке работают.

0

26

Кстати подписываю новым модулем Крипто Де и сертификатом ФК с новым алгоритмом ГОСТ 2012. Но на Портал этой ЭЦП меня не пускает. Захожу старой ЭЦП с алгоритмом ГОСТ 2001.

Отредактировано Сисадмин из Карелии (2019-01-16 17:26:15)

0

27

Сисадмин из Карелии написал(а):

simonoven написал(а):

    Код Безопасности CSP

То есть стоит не КриптоПро CSP 4.0, а Код Безопасности CSP. Или они в связке работают.


Так как на этом ПК стоит СУФД еще, там ставится Безопасности CSP. Попробую сегодня удалить ветку:

Далее находим и удаляем следующие ветки записей для Windows x64 — две, для систем разрядности x32 только первую.

    [HKEY_LOCAL_MACHINE/ SOFTWARE/ Microsoft/ Cryptography/ OID/ EncodingType 0/CryptDllFindOIDInfo/ 1.2.643.2.1.3.2.1!1]
    [HKEY_LOCAL_MACHINE/ SOFTWARE/ Wow6432Node/ Microsoft/ Cryptography/ OID/ EncodingType 0/ CryptDllFindOIDInfo\1.2.643.2.1.3.2.1!1]

0

28

Сисадмин из Карелии написал(а):

Кстати подписываю новым модулем Крипто Де и сертификатом ФК с новым алгоритмом ГОСТ 2012. Но на Портал этой ЭЦП меня не пускает. Захожу старой ЭЦП с алгоритмом ГОСТ 2001.

Отредактировано Сисадмин из Карелии (Вчера 17:26:15)

Еще ГОСТ 2012 не везде работает, тем более ЭП УФК.
Еще наткнулась на одну мысль для размышления, в самой программе КриптоПро - Алгоритмы - стоит ГОСТ 2001, не надо ли менять на ГОСТ 2012?

Отредактировано Mariya (2019-01-17 08:51:30)

0

29

simonoven написал(а):

Сисадмин из Карелии написал(а):simonoven написал(а):
                Код Безопасности CSP
            То есть стоит не КриптоПро CSP 4.0, а Код Безопасности CSP. Или они в связке работают.Так как на этом ПК стоит СУФД еще, там ставится Безопасности CSP. Попробую сегодня удалить ветку:
            Далее находим и удаляем следующие ветки записей для Windows x64 — две, для систем разрядности x32 только первую.
                [HKEY_LOCAL_MACHINE/ SOFTWARE/ Microsoft/ Cryptography/ OID/ EncodingType 0/CryptDllFindOIDInfo/ 1.2.643.2.1.3.2.1!1]    [HKEY_LOCAL_MACHINE/ SOFTWARE/ Wow6432Node/ Microsoft/ Cryptography/ OID/ EncodingType 0/ CryptDllFindOIDInfo\1.2.643.2.1.3.2.1!1]

У меня на компьютере с СУФД Крипто+ДЕ работал без конфликтов. Это со старым модулем. А эти ветки в реестре удаляются при установке Континента 3.7. Без их удаления не подписывается второй подписью.

0

30

Сисадмин из Карелии написал(а):

simonoven написал(а):

    Сисадмин из Карелии написал(а):simonoven написал(а):
                    Код Безопасности CSP
                То есть стоит не КриптоПро CSP 4.0, а Код Безопасности CSP. Или они в связке работают.Так как на этом ПК стоит СУФД еще, там ставится Безопасности CSP. Попробую сегодня удалить ветку:
                Далее находим и удаляем следующие ветки записей для Windows x64 — две, для систем разрядности x32 только первую.
                    [HKEY_LOCAL_MACHINE/ SOFTWARE/ Microsoft/ Cryptography/ OID/ EncodingType 0/CryptDllFindOIDInfo/ 1.2.643.2.1.3.2.1!1]    [HKEY_LOCAL_MACHINE/ SOFTWARE/ Wow6432Node/ Microsoft/ Cryptography/ OID/ EncodingType 0/ CryptDllFindOIDInfo\1.2.643.2.1.3.2.1!1]

У меня на компьютере с СУФД Крипто+ДЕ работал без конфликтов. Это со старым модулем. А эти ветки в реестре удаляются при установке Континента 3.7. Без их удаления не подписывается второй подписью.

Проблема, возникла при генерации на портале росказны ключей ЭП. При этом это решалось удалением Код Безопасности CSP, любо удалять ветку реестра.

0


Вы здесь » Партизанский форум про ЕГИССО » Регистрация и работа в ЕГИССО » crypto+DE отказывается работать с гостом 2001.